MobiusPi Python Development Quick Start

MobiusPi is the code name of InGateway series software and hardware products of Beijing InHand Networks Technology Co., Ltd. The InGateway includes two main product series, InGateway900 (IG900 for short) and InGateway500 (IG500 for short). This document aims to explain to users how to use the MobiusPi hardware product for Python development.

1.1 Building the MobiusPi Development Environment

1.1.1 Prepare Hardware and Network Environment

Connect MobiusPi to the Power Source and to a PC with a Network Cable

- Prepare IG500 Hardware
  
  Connect IG500 to the power source and to a PC with an Ethernet cable according to the topology diagram.

- Prepare IG900 Hardware
Connect IG900 to the power source and to a PC with an Ethernet cable according to the topology diagram.

**Set LAN Parameters**

- To set the IG500 LAN network parameters, see [Access the IG500 Through LAN](#).
- To set the IG900 LAN network parameters, see [Access the IG900 Through LAN](#).

**Set WAN Parameters**

- To set the IG500 WAN network parameters, see [Connect IG500 to the Internet](#).
- To set the IG900 WAN network parameters, see [Connect IG900 to the Internet](#).

**Update the Software**

To obtain the latest version and updated functions, contact the customer service center. To update the software, do as follows:

- Update the IG500 Software
- Update the IG900 Software

**Enable the Debug Mode of MobiusPi**

If you need to run and debug Python code on MobiusPi during development, you need enable the debug mode of MobiusPi.

- Enable the Debug Mode of IG500
- Enable the Debug Mode of IG900
1.1.2 Install Software on PC

Install a Python Interpreter

The PC must be installed with a Python2.7.X or 3.7.X interpreter (3.7.X is recommended). You can visit https://www.python.org/downloads/ to download the installation package and install it on your PC.
Install Visual Studio Code


Download the software and run the installation program. After the software is successfully installed, launch the VS Code software, as shown below.
Install OpenSSH

Obtain the OpenSSH tool from https://www.openssh.com and install it to the PC to make the PC support the SSH protocol.

1.1.3 Prepare the Development Environment of VS Code

Install the VS Code Plug-ins

To develop and debug Python code on MobiusPi, you need to install the following plug-ins in Extensions of VS Code IDE.

- **Python**: a VS Code Python plug-in with abundant functions and features, including IntelliSense, linting, debugging, code navigation, code formatting, Jupyter notebook support, refactoring, variable explorer, test explorer, snippets, and more! To get more information, visit the official website of the plug-in.

- **Project Templates**: a VS Code extended plug-in used to quickly create projects based on custom templates. We will release several Python App templates. You can use Project Templates to import templates and quickly initialize projects.

- **SFTP**: used to upload code to MobiusPi with the SFTP Sync plug-in.
Now, all the plug-ins required for developing MobiusPi edge computing platform are installed. To know more about VS Code plug-ins, visit Visual Studio Code official website.

**Configure the Python Interpreter Version**

Use the shortcut keys `Ctrl+Shift+P` to display the command interface. Enter `>Python: select Interpreter` in the command interface.
Select the required Python interpreter. In this source, Python 3.7.X interpreter is used. (The selected interpreter version should be the same as that in Edge Computing > Python Edge Computing > Edge Computing Engine.) Then the selected Python interpreter version is displayed on the left bottom of the VS Code interface.

Configure Project Templates

Use the Standard Project Templates of InHand

- Step 1: Download MobiusPi project template from here. MobiusPi provides various project templates for you to quickly initialize project directories. For details about project templates, see README.md. This course uses the standard project template “helloworld-template” as an exam-
Step 2: Open a project template. Decompress the downloaded project template package, run VS Code to open the helloworld-template folder, choose File > Open Folder, and select the helloworld-template folder.

Open the project template folder helloworld-template, as shown below. The project template includes:

- .vscode: VS Code configuration folder
  - sftp.json: SFTP plug-in configuration file, used to set up SFTP connections with the MobiusPi
- build: folder of App release package
– **lib**: App third-party dependent library folder

– **src**: folder of App source code

  * **main.py**: App entrance
  
  * **parse_config.py**: App configuration file parsing

– **config.yaml**: App configuration file

– **setup.py**: information such as App version and SDK version

• **Step 3**: Enter `>Project:Save Project as Template` on the command interface to save the current project file as a template.
Name your template, for example, helloworld-template.

**Customize Project Template**

- Step 1: Create a project template folder, which must include the following content. You can add other information according to your needs.
  
  - .vscode: VS Code configuration folder (Entering `>SFTP:Config` on the VS Code command interface can quickly create a .vscode folder and an sftp.json file.)
  
  * sftp.json: SFTP plug-in configuration file, used to set up SFTP connections with the
MobiusPi

- **build**: folder of App release package
- **src**: folder of App source code
  - *main.py*: App entrance
- **setup.py**: information such as App version and SDK version. It is recommended to customize the information based on the standard template.

- Step 2: Run VS Code to open the custom project template folder, choose File > Open Folder, and select the custom project template folder.

- Step 3: Enter `>Project:Save Project as Template` on the command interface to save the current project file as a template.

1.2 Compiling the First MobiusPi App: Hello World

In this course, an App named HelloWorld is used as an example to describe how to develop Python Apps with VS code on MobiusPi. This App can print a “hello world!” log on MobiusPi every 10s, import configuration files to modify log content.

1.2.1 Use Template to Create Project

- Step 1: Use VS Code to open the Python App project folder, as shown below:
- Step 2: Enter `>Project:Create Project From Template` on the command interface to quickly create a project directory by using an existing template.

- Step 3: Enter the template name of `helloworld-template` and press Enter.

After you select a template, VS Code automatically adds the files included in the template to the current project directory.
1.2.2 Coding

The standard project template helloworld-template can print a “hello world!” log on MobiusPi every 10s, import configuration files to modify log content. To change the App name, modify the code in `main.py` and `setup.py` as follows: (Note: The Python App names cannot contain spaces.)

Modify the app name to the corresponding app name in this document use "HelloWorld".
1.2.3 Debugging

Set Up an SFTP Connection

Before debugging code remotely, you need to upload the local code to a remote server, namely, the MobiusPi. Before uploading the code, ensure that the debug mode of MobiusPi has been enabled as follows:

- Step 1: Open the `sftp.json` file. Enter `>SFTP:Config` on the command interface to open the `sftp`.
• Step 2: Configure the SFTP connection.
  
  – Configure the IG500 SFTP connection

  In the `sftp.json` file, configure the SFTP connection according to the parameters on the Edge Computing > Python Edge Computing interface. Note: The Python App name must be the same as the App name in `main.py`.

  – Configure the IG900 SFTP connection

  In the `sftp.json` file, configure the SFTP connection according to the parameters on the Edge Computing > Python Edge Computing interface.
• Step 3: When the configuration is completed and saved, enter `>SFTP:Open` SSH in Terminal on the command interface to connect to the remote server.

• Step 4: You are prompted to select a folder. At this point, select the SFTP server in `sftp.json` and press Enter.
Step 5: If it is the first time to set up the SFTP connection, the TERMINAL window displays a message asking you whether to continue the connection. Enter Yes and press Enter. Enter `SFTP:Open SSH in Terminal` and SFTP server’s IP address on the command interface again.

Step 6: When the TERMINAL window prompts you to enter the password, you only need to copy the password in the `sftp.json` file.
When the SFTP connection is successfully set up with MobiusPi, the following information is displayed:

**Debug Code**

- Step 1: Synchronize code. After the SFTP connection is set up, right-click on a blank space in the left area and choose Sync Local > Remote from the shortcut menu to synchronize the local code to the remote server. After the code is synchronized, the modification or deletion of the local code will also be synchronized to the remote server.
You can check whether the remote server has received the App code in TERMINAL window. Enter the following commands in the TERMINAL window to show the uploaded App folder information:

```
\$ cd app
\$ ls -l
```

- **Step 2:** Debug the script in the TERMINAL window. After the code is synchronized, enter the command as follows to run the script on IG500. When the script is running, check whether the

---

1.2. **Compiling the First MobiusPi App: Hello World**
running result in the TERMINAL window printing “hello world!”.

```
python -m ptvsd --host 192.168.1.1 --port 3000 HelloWorld/src/main.py
```

- 192.168.1.1: IP address of FE 0/1 on IG500 (When using IG900, the IP address of GE 0/2 port should be filled in here)
- 3000: recommended debugging port number
- HelloWorld/src/main.py: execution path of main.py, which should be modified according to your needs.

The Python development environment of MobiusPi has a built-in ptvsd dependent library for remote code debugging. To learn about more usage information about ptvsd plug-in, see ptvsd usage.
Step 3: After debugging is completed, press Ctrl + C on terminal to terminate the debugging.

1.2.4 Construct App Release Package

When the debugging is completed, you can construct the App release package so that the App can be quickly deployed to other MobiusPis.

Step 1: Construct an App release package. Run the `build_py_app.sh Hello World` command in the TERMINAL window to construct an
Step 2: Download the App release package. An App release package is automatically generated in the build directory on the remote server. Right-click the local build folder and click Download Folder to download the constructed App release package for future deployment.

After the download is completed, you can see the HelloWorld App release package in the build directory.
1.2.5 Deploy App on the Web Page

After you run the App release package construction command, the App is automatically generated on the connected MobiusPi, but this App cannot be started normally. Please follow the procedure to deploy App to MobiusPi:

- Deploy App to IG500
- Deploy App to IG900
1.2.6 Check App Status

Choose Edge Computing > Python Edge Computing on the MobiusPi. You can see the running status of the App.

Click the log viewing icon to display the running log of the App.
1.2.7 Update Configuration File for App

- Step 1: Modify the configuration file. Modify `description: "hello world!"` in the `config.yaml` file of the App into `description: "hello inhand!"`.

```yaml
config:
  description: "hello inhand!"
  others:
    LOG:
      #Enable debug feature to write all logs to the console
      #Default: debug=0
      debug: 1
```

- Step 2: Import the configuration file and restart the App. Choose Edge Computing > Python Edge Computing on the MobiusPi, import the modified configuration file of HelloWorld, and restart the
After the restart, the HelloWorld App runs with the modified configuration file. That is, it prints a “hello

    DEBUG:root:Hello, world! Welcome to the Inhand!
    INFO:root:description:hello world!
    INFO:root:debug:1
    INFO:root:description:hello world!
    INFO:root:debug:1
    INFO:root:description:hello world!
    INFO:root:debug:1
    INFO:root:description:hello world!
    DEBUG:root:Hello, world! Welcome to the Inhand!
    INFO:root:description:hello inhand!
    INFO:root:debug:1
    INFO:root:description:hello inhand!
    INFO:root:debug:1
    INFO:root:description:hello inhand!
    INFO:root:debug:1
    INFO:root:description:hello inhand!
    INFO:root:debug:1

    inhand!” log every 10s.

1.2.8 Appendix

Use pip to Install the Dependent Library for App

To install the dependent library for App with pip, you need to enable the debugging mode for the MobiusPi and connect the MobiusPi to the Internet. The following uses the HelloWorld App to install the xlrd dependent library as an example to explain how to install third-party dependent libraries:
Step 1: Use VS Code to set up an SFTP connection with the MobiusPi. For details, see Set Up an SFTP Connection.
Step 2: Run `pip install + dependent library name + ==version number + -t + lib folder path of the App, and press Enter to install the dependent library. (If the version number is not included, pip automatically installs the dependent library of the latest version.)

```
pip install xlrd==1.2.0 -t /var/user/app/HelloWorld/lib/
```

Step 3: The dependent library is automatically downloaded and installed. When the installation is successful, the following information is displayed.
• Step 4: Run the `export` command to set the environment variables for the App. Run the following commands in the TERMINAL window.

```
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/var/user/app/HelloWorld/lib/
export PYTHONPATH=$PYTHONPATH:/var/user/app/HelloWorld/lib/
```

If a dependent library is installed for the App, you must configure the environment variables for the App before debugging; otherwise, the App cannot run normally during debugging. After enabling the
App in MobiusPi, the environment variables of the third-party dependent library in the App’s lib folder will be automatically added to the App, without manual configuration.

- Step 5: Execute code to ensure that the App runs normally.

Enable Automatic Code Completion

To improve the coding efficiency, enable automatic code completion by using Python extended plug-ins.

- Step 1: Choose File > Preferences > Settings.

- Step 2: Choose Extensions > Python. Find out Auto Complete: Extra Paths and click Edit in set-
Add the following items to settings.json and save the settings (python.pythonPath is the installation path of the Python interpreter.)

```json
"python.linting.pylintEnabled":false,
"python.linting.flake8Enabled":true,
"python.jediEnabled":true,
"terminal.integrated.rendererType":"dom",
"explorer.confirmDelete":false,
"python.pythonPath":"C:/Users/zm/AppData/Local/Programs/Python/Python37",
```
FAQs

Q1: What Can I Do If the Remote Host Key Is Change and Verification Fails During the Setup of an SFTP Connection?

A1: The possible reason is that the key of MobiusPi has been changed, but the key on the PC has not been updated. Therefore, the verification fails. You only need to delete the conflict line in the key file. (Pressing Ctrl and clicking the conflict item at the same time can quickly access the link.)
After the deletion, run the `>SFTP: Open SSH in Terminal` command again to create the SFTP connection.

Q2: After the SFTP Connection Is Successfully Set Up, I Right-Click the Blank Space in the Left Area, and Choose Sync Local > Remote to Synchronize Code to the Remote Server. However, All Authentication Methods Fail. What Can I Do?
A2: Ensure that the password in the sftp.json file is the same as the password of the MobiusPi. Then set up the SFTP connection and synchronize code again.

- Q3: I need to use IG900 serial port and network port during development. How to use it?

A3: The name of the RS485 serial port is: `/dev/ttyO3`; the name of the RS232 serial port is: `/dev/ttyO1`. Both serial and network ports can be invoked using Python’s standard serial / network port usage methods, such as using the `pyserial` library to call the serial port.

- Q4: SSH error is displayed when establishing an SFTP connection with MobiusPi. As shown below:
A4: Please install the OpenSSH tool to support the SSH protocol. You can obtain the OpenSSH tool from https://www.openssh.com.
This document is used to explain the basic configuration operations of InGateway501 (IG501 for short) networking, software version update, etc., so that users can master the basic configuration of IG501 and the use of common functions.

2.1 Configure IG501 Network Parameters

2.1.1 Set LAN Parameters: Access the IG501 Through LAN

- Step 1: Set the PC’s IP address to be on the same subnet with FE 0/1. By default, the IP address of FE 0/1 on IG501 is 192.168.1.1.
  - Method 1: Enable the PC to obtain an IP address automatically (recommended)
Method 2: Set a fixed IP address

Select Use the following IP address, enter an IP address (By default, any from 192.168.1.2 to 192.168.1.254), subnet mask (By default, 255.255.255.0), default gateway (By default, 192.168.1.1), and DNS server address, and click OK.
Step 2: Launch the browser on the PC and access the IP address of FE 0/1. Enter the login user name and password. The default user name and password are adm and 123456 respectively.

After successful login, you can see the web page as shown below:
Step 4: To change the user name and password for logging in to the web management interface of IG501, choose System > User Management page of IG501 and set the new user name and password.

Step 5: To change the IP address of FE 0/1, choose Network > Network Interfaces > Ethernet page of IG501 to configure FE 0/1.
2.1.2 Set WAN Parameters: Connect IG500 to the Internet

- Step 1: Insert the SIM card. (Note: Before inserting or removing the SIM card, unplug the power cable; otherwise, the operation may cause data loss or damage the IG500.) After inserting the SIM card, connect the 4G LTE antenna to the ANT interface and power on the IG500.

- Step 2: Choose Network > Network Interfaces > Cellular and select Enable Cellular.
When the network connection status is Connected and an IP address has been allocated, the IG500 has been connected to the Internet with the SIM card.

### 2.2 Update the Software

To obtain the latest software version of IG501 and updated functions, contact the customer service center. To update the IG501 software version, do as follows:

- Update the IG501 firmware. Choose System > Firmware Upgrade. Select a firmware file and click Start Upgrading. After the update is completed, you are prompted to restart the system to Apply the new firmware.
2.3 Use Python Edge Computing

2.3.1 Install and run Python App

To install and run Python App (App for short) in IG501, please refer to the following process:

- Step 1: Install the App Before installing the App, you need to ensure that the Python Edge
Computing Engine is enabled and the Python SDK is installed, as shown in the following figure:

Choose Edge Computing > Python Edge Computing, click the Add button and select the App package file to be installed, then click OK.

After importing, you can view the imported Apps, as shown in the following figure:
• **Step 2:** Run the App Select enable App and click Submit.

Once enabled, the App automatically runs and will run every time the IG501 is started.
### 2.3.2 Update Configuration File for App

If the installed App supports importing configuration files to modify the running mode, you can update the App running configuration by referring to the following process:

- **Step 1:** Choose Edge Computing > Python Edge Computing, click the Import Configuration button and select the configuration file to be imported, then click Confirm.

- **Step 2:** Restart the App after the import is successful. After the App restarts, it will run according to the imported configuration file.
2.3.3 Enable the Debug Mode


After the debugging mode is enabled, IG501 will start an SSH server to listen on port 222 of LAN (default IP address being 192.168.1.1). The user name and password of the SSH server are displayed on the previous web page. A random password is generated every time the debugging mode is enabled or the IG501 is restarted to ensure security.
2.4 Appendix

2.4.1 Factory reset

There are two ways to restore the IG501 to factory settings: hardware factory reset and software factory reset.

- **Hardware factory reset**
  - Step 1: After the device is powered on and the ERR light is off, press and hold the RESET key;
  - Step 2: When the ERR light is always on, release the RESET key;
  - Step 3: After the ERR light goes out, press and hold the RESET key again, and release the RESET key when the ERR light flashes; wait for the ERR light to go out, indicating that the factory reset was successful.

- **Software factory reset**
  Choose System Management > Configuration Management, click the reset button and select OK. IG501 will complete the factory reset operation by itself.
This document is used to explain the basic configuration operations of InGateway902 (IG902 for short) networking, software version update, etc., so that users can master the basic configuration of IG902 and the use of common functions.

3.1 Configure IG902 Network Parameters

3.1.1 Set LAN Parameters: Access the IG902 Through LAN

- Step 1: Set the PC’s IP address to be on the same subnet with GE 0/2. By default, the IP address of GE 0/2 on IG902 is 192.168.2.1.
  - Method 1: Enable the PC to obtain an IP address automatically (recommended)
- Method 2: Set a fixed IP address Select Use the following IP address, enter an IP address (By default, any from 192.168.2.2 to 192.168.2.254), subnet mask (By default, 255.255.255.0), default gateway (By default, 192.168.2.1), and DNS server address, and click OK.
Step 2: Launch the browser on the PC and access the IP address of GE 0/2. Enter the login user name and password. The default user name and password are adm and 123456 respectively.

After successful login, you can see the web page as shown below:

- After successful login, you can see the web page as shown below:
Step 4: To change the user name and password for logging in to the web management interface of IG902, choose System > User Management page of IG902 and set the new user name and password.

Step 5: To change the IP address of GE 0/2, choose Network > Network Interfaces > Ethernet > Gigabitethernet 0/2 page of IG902 to configure GE 0/2.
3.1.2 Set WAN Parameters: Connect IG902 to the Internet

- Method 1: Connect to the Internet by SIM card
  - Step 1: Insert the SIM card. (Note: Before inserting or removing the SIM card, unplug the power cable; otherwise, the operation may cause data loss or damage the IG902.) After inserting the SIM card, connect the 4G LTE antenna to the ANT interface and power on the IG902.
Step 2: Choose Network > Network Interfaces > Cellular page of IG902 and select Enable Cellular and click Submit.

Press the SIM card into the card slot

Connect PC

ANT antenna
When the network connection status is Connected and an IP address has been allocated, the IG902 has been connected to the Internet with the SIM card.

- Method 2: Connect to the Internet by Ethernet
  - Step 1: Use the Ethernet cable to connect the GE 0/1 and GE 0/2 ports of the IG902 respectively, as shown below:
Step 2: Choose Network > Network Interface > Ethernet > Gigabit Ethernet 0/1 page of IG902 to configure the IP address of the GE 0/1 port and click Submit. (When the network type is a static IP address, you need to configure the IP, subnet mask, and other information according to the site network conditions.)
– Step 3: Choose Network > Static Routing > Configuration page of IG902 to add a static route for GE 0/1 port and click Submit. (Select “Gigabitethernet 0/1” for the interface item, and configure the other items according to the site network conditions.)
Step 4: Choose System > Network Tools page of IG902 and use the Ping tool to check whether the IG902 has successfully connected to the Internet. The following figure shows that IG902 have successfully connected to the Internet:

3.2 Update the Software

To obtain the latest software version of IG902 and updated functions, contact the customer service center. To update the IG902 software version, do as follows:

- Update the IG902 firmware. Choose System > Firmware Upgrade. Select a firmware file and click Start Upgrading. After the update is completed, you are prompted to restart the system to Apply the new firmware.
• Upgrade the Python SDK of IG902. Choose Edge Computing > Python Edge Computing. Select Python Engine, select an Python SDK file, and click Upgrade; when the upgrade confirmation window pops up, click Confirm. Then the IG902 automatically performs the upgrade.

• Upgrade the Docker SDK of IG902. choose Edge Computing > Docker Manager, close the Docker Manager and import the Docker SDK.
After importing, IG902 will automatically install the Docker SDK. The installation process usually takes 1-2 minutes. Please be patient. After successful installation, select Enable Docker Manager and click Submit.

After enabling the Docker Manager, you can click the access button of the Docker Manager to access the management page.
Enter the account and password set in the figure above to log in to the Docker Manager.

3.3 Use Python Edge Computing

3.3.1 Install and run Python App

To install and run Python App (App for short) in IG902, please refer to the following process:

- Step 1: Install the App Before installing the App, you need to ensure that the Python Edge Computing Engine is enabled and the Python SDK is installed, as shown in the following figure:
Choose Edge Computing > Python Edge Computing. Click the Add button and select the App package file to be installed, then click OK.

After importing, you can view the imported Apps, as shown in the following figure:
• Step 2: Run the App. Select enable App and click Submit.

Once enabled, the App automatically runs and will run every time the IG902 is started.
3.3.2 Update Configuration File for App

If the installed App supports importing configuration files to modify the running mode, you can update the App running configuration by referring to the following process:

• Step 1: Choose Edge Computing > Python Edge Computing, click the Import Configuration button and select the configuration file to be imported, then click Confirm.

• Step 2: Restart the App after the import is successful. After the App restarts, it will running according to the imported configuration file.
3.3.3 Enable the Debug Mode

To run and debug Python code on IG902, you need to enable IG902’s debug mode. Choose Edge Computing > Python Edge Computing, select Enable Debug Mode. After enabling, you can develop IG902 through VS Code. How to use VS Code for Python development of IG902, please refer to Python Development Quick Start.

After the debugging mode is enabled, IG902 will start an SSH server to listen on port 222 of LAN (default IP address being 192.168.2.1). The user name and password of the SSH server are displayed on the previous web page. A random password is generated every time the debugging mode is enabled or the IG902 is restarted to ensure security.
3.4 Appendix

3.4.1 Factory reset

There are two ways to restore the IG902 to factory settings: hardware factory reset and software factory reset:

- **Hardware factory reset**
  - Step 1: After the device is powered on and the ERR light is off, press and hold the RESET key;
  - Step 2: When the ERR light is always on, release the RESET key;
  - Step 3: After the ERR light goes out, press and hold the RESET key again, and release the RESET key when the ERR light flashes; wait for the ERR light to go out, indicating that the factory reset was successful.

- **Software factory reset**
  Choose System Management > Configuration Management, click the reset button and select OK. IG902 will complete the factory reset operation by itself.
InGateway902 series edge computing gateway (IG902 for short) supports manage docker images. You can publish your docker images to IG902 to quickly deploy and run applications developed by yourself. In order to introduce how to use IG902’s Docker environment, this document will demonstrate how to run an Nginx image on IG902. This image is used for open source reverse proxy server for HTTP, HTTPS, SMTP, POP3 and IMAP protocols, and load balancer, HTTP cache And web server. Docker is an open source application container engine that allows developers to package their applications and dependencies into a portable container and then publish it to any popular Linux machine or Windows machine. It can also be virtualized. The container is completely with the sandbox mechanism, there will be no interface between each other.
4.1 Prepare IG902 Hardware and Network Environment

4.1.1 Connect IG902 to the Power Source and to a PC with a Network Cable

Connect IG902 to the power source and to a PC with an Ethernet cable according to the topology diagram.

![IG902 diagram](image)

Set LAN Parameters: Access the IG902 Through LAN

To set the IG900 LAN network parameters, see Access the IG900 Through LAN.

Set WAN Parameters: Connect IG902 to the Internet

To set the IG900 WAN network parameters, see Connect IG900 to the Internet.

4.1.2 Update the firmware

To obtain the latest firmware version of IG902 and updated functions, contact the customer service center.
To update the IG902 firmware, see Update the IG900 Software. (The firmware version should be 2.0.0.r12057 and above)

4.2 Enable and configure Docker manager

4.2.1 Install Docker SDK and enable Docker manager

The Docker SDK integrates the operating environment and docker image manager required to run the docker image. Before using Docker, you must install the Docker SDK. To obtain the Docker SDK, please contact
In Gateway Documentation, Release 0.0.1

the customer service center.

- **Step 1:** If you already have the Docker SDK, choose Edge Computing > Docker Manager page of IG902, close the Docker Manager and import the Docker SDK.

- **Step 2:** After importing, IG902 will automatically install the Docker SDK. The installation process usually takes 1-2 minutes. Please be patient. After successful installation, select Enable Docker Manager and click Submit.

- **Step 3:** Then you can modify the port number and login password to access the Docker manager.

4.2. Enable and configure Docker manager
4.2.2 Configure Docker Manager–Portainer

IG902 uses Portainer to build, manage and maintain Docker images and containers. For a detailed introduction and instructions on Portainer, please see the Portainer official website. This document will show you how to add and deploy an Nginx docker image on IG902.

Access Portainer

- Step 1: Click Portainer’s access button, and Portainer will prompt you to enter your username and password. At this time, copy the user name and the set password from the Edge Computing > Docker Manager page of IG902 and click Login.
• Step 2: After the login is successful, as shown in the figure below, select Local to use the Portainer to manage the docker image on the IG902, and then click Connect.

• Step 3: On the Home page of Portainer, select local to manage the docker image on IG902.
Then you will jump to the local dashboard, where you can get an overview of the IG902’s containers and images.

**Add docker image**

There are two ways to add docker images for Portainer:

- **Method 1:** Import the local docker image from the Edge Computing > Docker Manager page of IG902. (The time required for import varies depending on the size of the docker image; please be patient when the docker image is large.)
You can see the docker image successfully imported on the Local > Images page of Portainer.

- Method 2: Choose Local > Images page of Portainer and download the nginx docker image from DockerHub. (The time required to download the image varies depending on the size of the image; please be patient when the docker image is large)
After the docker image is downloaded, you can see the corresponding docker image information in Local > Images as shown below:
Configure and deploy container

- Step 1: Choose Local > Containers page of Portainer and click Add container to add a new container.

- Step 2: Configure the operating parameters for the container and deploy the container.

- Step 3: The container will run automatically after deployment. You can view the container running status on Portainer’s Local > Containers page.
Step 4: After entering the Nginx access link (IP address + port number of IG902) configured in the container in the browser, you can see the Nginx welcome page. This shows that the Nginx docker image has been running on the IG902 normally. Now, you have completed adding and deploying an Nginx docker image on the IG902.
4.3 Appendix

4.3.1 How to download docker images from gitlab / github

Choose Local > Registries page of Portainer and click Add registry to add a docker mirror repository (must be a public repository).

Then select Custom registry and configure the mirror repository information. After configuration, click Add registry.

After the mirror repository is successfully added, you can see the web page as shown below:
After the addition is successful, you can select the configured image repository when pulling the docker image.